Detailed Help

Back to First Time Here

Registration

You may use Our Environment without registering, however some functionality of the site will not be available to you until you register, like saving your pins / features and sharing reports. Registering is quick and easy, and completely free. To register, click here.

 

Quick Links

Use one of the links below to jump to what you're keen to learn about.

About the map page

How to find a location on the map

About our map layers

How to create reports

How to print your map

Downloading the data

More advanced features

About the Landcover Explorer

 

The Home Page

The home page provides various buttons and links to help you navigate around the site.

Clicking on the explore maps button Explore the Atlas button or the Maps & Tools > Explore NZ Land Atlas link in the top navigation bar, will take you to a page where you can select and view environmental maps of New Zealand.

Clicking on the locate me button Locate me button will take you to the maps page, with the map displayed showing your current location. This functionality is enabled only if you are located within New Zealand.

Finally, clicking on the first time here button First time here? button (or Help > First Time Here from the top navigation bar) will bring you to this page.


 

Maps

The map page consists of a main map window, surrounded by a series of panels and controls which enable map navigation, map viewing, querying for data, reporting and printing of the environmental map layers. These panels can change dependent on actions carried out in the map. For instance, the ADD FEATURES panel (Fig. 1) becomes the FEATURE REPORT panel (Fig. 2) after a feature is queried from the map.

map page main

Fig. 1. Map page.

 

1. Map window - Interact with and view maps. Learn more.

2. Control panel - Various controls. Learn more.

3. SEARCH panel - Search for a particular location using geographic coordinates, a place name or an address. Learn more.

4. LAYERS panel - Control which layers are drawn on the map. Tick check boxes to turn layers on or off. Click layer name to view information about a layer. This will be displayed in the METADATA panel. Learn more.

5. LEGEND panel - Displays a map key.

6. METADATA panel - Displays descriptive information about the selected map layer, including a link to download the original data, if available.

7. Navigation panel - Links to different pages of the site and other sites of interest.

8. ADD FEATURES panel - Add features of interest to the map to generate a report. Choose from point, area, map extent or predefined features. The data displayed depends on which science layer you have selected. The information is returned in this panel, but it gets renamed to 'FEATURE REPORT'. See 10, below. Learn more.

9. MY FEATURES panel - If you save a pin, this is where they will appear.


map page main

Fig. 2. Map page, after feature information query.

 

10. FEATURE REPORT panel - Returned information is displayed here. Learn more.

11. Dropped feature information pin.

12. Saved pin - Return to report for that pin at later date.

13. Report preview window - Short version of generated report. Click on more detail link at top for additional information. Click on title: 'Report Preview' to open dropdown which enables switching of layer report is generated for.

14. Add/Remove Layers button - change the layers which are available on the map.


 

The Map Window

This window contains various controls which you can use to interact with the map. You can also interact with the map (zoom in and out) using tools in the Control Panel.


map panel

Fig. 3. Map window.

 

  1. Zoom buttons - Zoom in and out of the map.
  2. Layer transparency - Alter the transparency of the environmental science layers.
  3. Overview map - Shows the larger geographic context of your current map.
  4. Locate me - Zoom map to your current location.
  5. Scale bar.
  6. Attribution - Copyright information.


 

The Control Panel

This panel contains a number of controls relating to map interaction and interrogation, along with other functionality such as printing, sharing and advanced settings.

control panel

Fig. 4. Control Panel.

 

  1. Reset - Reset map and layers to default settings.
  2. Set map scale - Zoom in and out by changing the map's cartographic scale. This is approximate.
  3. Previous / next extent - Cycle between previously viewed maps.
  4. Full screen - Switch to full screen mode.
  5. Max extent - Zoom the map to full geographic extent.
  6. Zoom to rectangle - Draw a box on map by clicking and dragging out a box. The map will redraw using your rectangle as the map extent. (Mode change)
  7. Share map - Create a URL link which you can copy to share the current map with other users.
  8. Print map - Open the print window to create a custom PDF.
  9. Send Feedback - Opens the contact form for sending us feedback or telling us about a problem you are having.
  10. Help - Display summary help window.
  11. Settings - Displays the advanced settings window. In this window you can change the image resolution of the map, allow more control of map layers, and change the interaction style between mouse and touch (if you have a touch enabled device).


 

Interacting with the map

To move around the map, click and drag the map to pan (move) to another location.

You can zoom into the map (to see more detail) and zoom out of the map (to see less detail) in a number of ways.

  • To view more or less map detail, use the zoom buttons (3a).
  • Double-click to zoom in closer or use your mouse's scroll wheel to zoom in and out.
  • To zoom to a particular portion of the map, you can switch to "Zoom to rectangle" mode (4f) by clicking the  button. Click and drag out a box of the map area you are interested in. Release the mouse button. After releasing the mouse button, the map will automatically zoom to the area that was selected. You need to select the  button to turn off zoom mode.
  • Alternatively, while holding down the SHIFT key, click and drag out a box of the map area you are interested in. Release the mouse button.
  • If needed, you can repeat the same steps to zoom further into the area. Finally, to zoom to a particular scale e.g., 1:25,000, select a scale from the scale drop down menu (4b).

To move quickly to a particular part of the country, use the Overview map (3c). The Overview map shows you your current location on a smaller scale map. You can move the current map view to another location by clicking on the overview map, or by clicking and dragging the small crosshair / dotted box. To hide the overview map, click on the "«" button to the bottom left of the overview map.


 

Finding a particular place on the map

If you are looking for a particular place, the quickest way to find it is to use the SEARCH tool (3). Searching works with geographic coordinates, a place name or an address.

To search using a place name or an address

If searching for a place name or address, the tool should recognise what you are typing and show you a list of suggestions. From the suggestions list, click on a place name or address to display the map of that location. You can also select a place name or address using the up and down arrow keys and the enter key.

To search using coordinates

Type the coordinates into the search box. You can type NZTM coordinates (e.g. 1890671, 5819114) or latitude-longitude (e.g. -37.73, 176.29). Press the return key to display the map of that location.

In all cases, the place you are looking for is shown on the map by a red flashing dot.


 

Viewing map layers including environmental science layers

When you first use the mapping tool, you will be presented with a popup window and asked to select one or more environmental science layers to view on the map.

You can select which layers appear in the LAYERS panel (4) by clicking the ADD/REMOVE LAYERS button. This opens a popup window (shown below) which gives three ways to browse the available map layers: by Topic, Category or Source.

Topic: Displays a picture related to the map layer, and a question that the data can help answer.

Category: Splits the map layers in to environmental categories.

Source: Organises map layers by their source.

configure your map

Fig. 5. Configure your map.

 

Select which layers you would like added to the LAYERS panel (4), then click the Explore Map button.

 

You can then view the different environmental science layers using the LAYERS panel (4).

In the LAYERS panel, tick a box to view the layer on the map. Tick another box to view another layer. Only one science layer can be viewed at a time on the map. However, for many layers, you can turn on or off specific features (classes) within a layer to view just those classes on the map you are interested in.

N.B. For certain layers, you may need to zoom in or out of the map, before that layer becomes visible. You should see a message like "Water Yield becomes visible when zoomed out". This ensures you are not viewing maps at inappropriate scales.

 

Learning about a particular map layer

The METADATA panel (7) displays background information about the layer you have currently selected. Further details about particular features (classes) making up a layer can be found in the LEGEND panel (6). To view this information, click on a layer in the LAYERS panel (4), and make sure the METADATA (7) or LEGEND panel (6) is open. The active layer will be highlighted.


 

View information for a particular location / area

You can view a report for a selected layer in the ADD FEATURES / FEATURE REPORT panel (Fig.6).

You can obtain reports either for a single location, for an area you define yourself on the map, the current map extent (window), or for areas (polygons) you select on the map from either the LINZ property boundaries, Māori Land Blocks, Territorial Authorities or the Regional Councils layers.

Step 1) If you haven't already down so, choose a science layer to display on the map. Reports are displayed faster if you have zoomed in to a small area on the map.

Step 2) Choose what you want the report to be based upon. Choices are: drop pin Drop pin on map, draw area Draw area on map, map extent Use map extent, or "Predefined features", such as polygons you select from LINZ Parcels, Māori Land Blocks, Territorial Authorities or Regional Councils.

Step 2a) DROP PIN: the report will be generated by you clicking on a location on the map. A pin marker will appear at the location you have clicked.

Step 2b) MAP EXTENT: the report will be generated using the current visible extent, in the map window. Choosing this option will then generate a report for the map extent.

Step 2c) AN AREA YOU DRAW: the report will be generated using an area defined/drawn by you. If you choose this option you need to define your area by clicking multiple times around the map, to create a custom area. You should use the mouse to draw an area on the map.

  • Click on the map to add a point and begin drawing
  • Subsequent clicks will add additional points
  • Click back close to the starting point, or double click anywhere, to finish and generate a report.

Step 2d) "Predefined features": the report will be generated from the selected LINZ property boundary / Māori Land Block / Territorial Authority (TA) or Regional Council (RC). Choosing this option will switch on the corresponding layer (if not currently on) and it will be displayed on the map. You must then click on the map within the area you want included in the report. The area you have selected will be highlighted. A report will be generated for that area. If you click on additional parcel / area, they will be highlighted and the values will be added to the report. To remove a parcel / area from the report, click inside the parcel / area again to deselect it. To deselect all parcels / areas and start again, click on START AGAIN. Note that the LINZ property boundaries and Māori Land Block layers are best viewed at a large scale (zoomed in), perhaps at 1:25,000, although for very rural areas you will probably need to view the map at smaller scales (more zoomed out). Similarly, the Territorial Authorities and Regional Councils layers are best viewed at smaller scales (zoomed out), perhaps at 1:2,000,000. Below the generated report, there is a switch which allows you to show / hide the layer in question.

Once the report has been requested using one of the above methods, this panel will change to FEATURE REPORT and a report preview will appear. The form of this report depends which type of report has been chosen. For example, if you chose "Drop pin on map", a textual report will appear listing attributes about that location, key properties, the Easting/Northing coordinates for that location, and an approximate height. If you chose "Draw area on map" or one of the predefined features options, the report preview will be in the form of a chart, with information relating to the classes that make up the chosen map layer.


add feats > feat report

Fig. 6. ADD FEATURES panel becomes FEATURE REPORT panel, after report is generated.

 

Select the BACK button to go back to Step 2.

If you choose another science layer (by clicking the layer name to open a dropdown menu), the report will be automatically updated. However, the report is NOT updated if you pan or zoom to another location. In this case you will need to select the BACK button, and start again at Step 2.

Step 3) Full Report: Click the "Generate full report" button, and a more detailed report will be generated for the location / area in question. This opens in a new window an example of which can be seen below in Fig. 7. The report is then accessible in your MY FEATURES panel, after you close the report window.


report window

Fig. 7. Report window.

In this window you can interact with the report in a variety of ways:

  • Edit the report title - Click  button to go into edit mode, and edit text in the grey box at the top of the report.
  • View the location / area of the report in a mini map in the top right of the report window.
  • Add / remove data layers to / from the report - Click on the "Add/remove layers" button, and check / uncheck required layers from the resultant window.
  • Change the visualisation type by clicking on the buttons directly above the chart - choose from Bar, Tree, Bubble or Table.
  • Generate a shareable link to the report by clicking the  button.
  • Print the report by clicking the  button and following the instructions in the print window dialog.

Important things to be aware of:

  • The larger the geographic extent of the map, the longer it will take for the report to be calculated and the report displayed. In some cases, because of the complexity of the underlying data, the reporting tool will not work if the map is displaying a very large geographic extent.

Share a report

Select the SHARE button to generate a link for the report you have chosen. Please note, this option is only available if you are registered, and logged in. This link can then be shared with others e.g. in an email. If the person receiving the link clicks on it, their browser will open, Our Environment will load, they then need to log in and then the area report you specified will be displayed to them. The individual provided with the link will need to be a registered Our Environment user.

 

Saving your Pins / Features

If you have registered, and are logged in, you can save your pin / feature so that it's available when you login again later. If you want you can give the pin / feature a name. Do this before clicking the SAVE button. Choosing SAVE will add the pin to the MY FEATURES panel (5). Pins are stored and will appear in the MY FEATURES panel when you next use Our Environment. You can delete saved pins using the DELETE button. You can also zoom the map to the location of a saved pin by clicking the checkbox for the pin and clicking on the ZOOM TO button.

Deleting Pins / Features

You can delete a pin or feature by clicking REMOVE in the FEATURE REPORT panel.


 

Download the underlying data

We provide a link, Obtain Data in the Layer METADATA if the data used to produce a map layer is available for downloading. If you click on the link, the relevant page from the website hosting the data will appear in a new browser window. In most cases this will be Manaaki Whenua's LRIS Portal.


 

Printing a map

Use the Print facility (4h) to create printable PDF maps in A4 and A3 size, in portrait or landscape layout and at various scales.

Click on the  Print Map icon (4h) to open the PRINT window. The extent of your map is shown by the pink box. Click on the box and drag it around to change the geographic location of your map.

Changing the scale or paper size will affect the amount of detail or the size of the geographic area that will appear on the map.

You can enter a title for the map.

To request the PDF file, click on 'CREATE AND DOWNLOAD MAP' button.

Note that the time it takes to create the PDF file will vary depending upon the complexity, size and scale of the map. You may have to wait a couple of minutes for the file to be created and downloaded. Depending on how your computer and browser are set up, you will either be able to view the PDF file directly or save it to your computer.


 

More advanced map features

 

Adding custom layers (*Experimental feature*)

Our Environment Online can display third party maps that are served with the Web Map Tile Service (WMTS) protocol or Esri ArcGIS REST API. To add a third party layer press the "Add 3rd party layer" button which is in the "Configure your map" window. This window is accessed via the "ADD/REMOVE LAYERS" button.

WMTS

Paste a WMTS capabilities URL in the box provided, and click the LOAD button. If the URL is valid, you will be presented with the layers available via that service. Choose which group you would like the layer to be added (Context / Science / Basemap), and click the tick button. The layer will be added in to the LAYERS panel. For example, click here to use the layers from Manaaki Whenua's Web Map Services.

You can find some compatible maps at:

This feature works best with maps that are in the NZTM projection but we try to re-project on the fly if the maps are in a different projection. The WMTS service obviously needs to provide maps that cover or fall entirely within New Zealand. You will see an error message if the map coverage is outside of New Zealand.

Esri ArcGIS REST API

Paste a Esri ArcGIS REST API URL in the box provided, and click the LOAD button. If the URL is valid, you will see information relating to the layer - click the tick button to confirm and add the layer to your map. The URL for the service should end with:

  • /MapServer - for example NZ Imagery
  • /MapServer/{a number} e.g. /MapServer/0 /MapServer/1 /MapServer/2 etc.
  • /ImageServer - for example NZ Bathymetry 250m

You can find some compatible maps at:

  • data.govt.nz - when you select a dataset, choose the Esri REST API option, then paste the URL of the resource into the text box above.
  • Living Atlas - when you click on a layer, you will be shown a page with information about the layer. To import this into Our Environment, copy the links that are in the section titled Layers.

 

Altering the transparency of a map layer

You can use the Layer Transparency slider (3b) to vary the transparency of a layer displayed on the map. This allows you to gradually fade-in/fade-out the layer against the basemap.

 

Activating Locate Me functionality from within the map

Click the Locate Me (3d) button to zoom the map to your current location (within NZ only).

 

Changing the underlying base map

By default, map layers are shown on top of a topographic map. However, some map layers are easier to read on top of alternative base maps (e.g. "monochrome topographic"). You can change the basemap by selecting a different base map in the LAYERS panel (4).

 

Resetting the map back to a national extent

At any time you can click the globe icon (4e) on the top bar to reset the map extent back to the whole of New Zealand.

 

Returning to a previous map view

Use the back arrow (4c) in the toolbar to see the maps you were looking at previously. You can also use the forward arrow (4c) to go forward through the maps you have looked at previously.

 

Maximise the size of the map you can see on the screen

You can hide all various information panels, thus increasing the size of the map you can see on the screen. To do this, click on the name / icon of the panel you wish to minimise. Clicking on the name / icon again, opens the panel.

 

Go Full Screen

You can make the browser window go into full screen mode by clicking on the  button (4d) .

 

New Zealand Landcover Explorer

This is a currently experimental map tool that allows you to view changes and issues relating to New Zealand's land cover, by exploring different versions and 'views' of the Landcover Database NZ.

To access it, select the "Maps & Tools" > "Explore Landcover" option from the menu at the top of the page (or click here). On first load of the tool, it is recommended to choose the "Take a tour" option from the popup window, as this will give you a quick overview of how the site works.

N.B.

  • Landcover maps don't appear until you zoom in to the map to around 1:550k.
  • The direction of change buttons: landcover explorer button landcover explorer button allow you to switch the map between looking at where land cover has become a particular type and where land cover is no longer a particular type.

Back to First Time Here

Registration

You may use Our Environment without registering, however some functionality of the site will not be available to you until you register, like printing, saving your pins / features and sharing reports. Registering is quick and easy, and completely free. To register, click here.

 

Quick Links

Use one of the links below to jump to what you're keen to learn about.

About the map page

How to find a location on the map

About our map layers

How to create reports

How to print your map

Downloading the data

More advanced features

About the Landcover Explorer

 

The Home Page

The home page provides various buttons and links to help you navigate around the site.

Touching the explore maps button Explore the Atlas button or the Maps & Tools > Explore NZ Land Atlas link at the top of the page will take you to a page where you can select and view environmental maps of New Zealand.

Touching the locate me button Locate me button will take you to the maps page, with the map displayed showing your current location. This functionality is enabled only if you are located within New Zealand.

Finally, tapping the first time here button First time here? button (or Help > First Time Here from the top navigation bar) will bring you to this page.


 

Maps

The map page consists of a main map window, surrounded by a series of panels and controls which enable map navigation, map viewing, querying for data, reporting and printing of the environmental map layers.


map page main Fig. 1. Map page.

1. Map window - Interact with and view maps.

a. Zoom buttons - Zoom in and out of the map.

b. Layer transparency - Alter the transparency of the environmental science layers.

c. Overview map - Shows the larger geographic context of your current map.

d. Locate me - Zoom the map to your current location.

e. Attribution - Copyright information.

f. Scale Bar.

2. Control panel - Various controls relating to interacting with the map and querying for data, printing, sharing and advanced settings.

a. Reset - Reset map and layers to default settings.

b. Set map scale - Zoom in and out by changing the map's cartographic scale. This is approximate.

c. Previous / next extent - Cycle between previously viewed maps.

d. Full screen - Switch to full screen mode.

e. Max extent - Zoom map to full geographic extent.

f. Share map - Create a URL link to share the current map with other users.

g. Print map - Open the print window to create a custom PDF.

h. Send Feedback - Opens the contact form for sending us feedback or telling us about a problem you are having.

i. Help - Display summary help window.

j. Settings - Displays the advanced settings window. In this window you can change the image resolution of the map, allow more control of map layers, and change the interaction style between mouse and touch (if you have a touch enabled device).

3. SEARCH panel - Search for a particular location using geographic coordinates, a place name or an address. Learn more.

4. MY LAYERS panel - Control which layers are drawn. Tick check boxes to turn layers on or off. Touch layer name to view layer information, which will be displayed in the LEGEND panel. Learn more.

5. MY FEATURES panel - Saved pins and features, generated from the FEATURES panel, will appear here.

6. LEGEND panel - Displays a map key.

7. METADATA panel - Displays descriptive information about the selected map layer, including a link to download the original data, if available.

8. FEATURES panel - Generate reports by touching the map to add pins, areas (polygons) or choose from predefined areas. Learn more.

9. Navigation panel - Links to different pages of the site and other sites of interest.


 

Interacting with the map

To move around the map, tap and drag the map to pan (move) to another location.

Use one of the following to zoom into the map (see more detail) and zoom out (see less detail).

  • Use the zoom buttons (1a).
  • Double-tap to zoom in closer or use a pinch action to zoom in and out.
  • To zoom to a particular scale e.g., 1:25,000, select a scale from the scale drop down menu (2b).

To move quickly to a particular part of the country, use the Overview map (1c). The Overview map shows you your current location on a smaller scale map. You can move the current map view to another location by tapping in the overview map where you'd like the map to move to. To hide the overview map, tap the "«" button to the bottom left of the overview map.


 

Finding a particular place on the map

If you are looking for a particular place, the quickest way to find it is to use the SEARCH tool (3). Searching works with geographic coordinates, a place name or an address.

To search using a place name or an address

If searching for a place name or address, the tool should recognise what you are typing and show you a list of suggestions. From the suggestions list, tap on a place name or address to display the map of that location.

To search using coordinates

Type the coordinates into the search box. You can type NZTM coordinates (e.g. 1890671, 5819114) or latitude-longitude (e.g. -37.73, 176.29).

In all cases, the place you are looking for is shown on the map by a red flashing dot.


 

Viewing map layers including environmental science layers

When you first use the mapping tool, you will be presented with a popup window and asked to select one or more environmental science layers to view on the map.

You can select which layers appear in the MY LAYERS panel (4) by clicking the ADD/REMOVE LAYERS button. This opens a popup window (shown below) which gives three ways to browse the available map layers: by Topic, Category or Source.

Topic: Displays a picture related to the map layer, and a question that the data can help answer.

Category: Splits the map layers in to environmental categories.

Source: Organises map layers by their source.


map panel Fig. 2. Configure your map.

Select which layers you would like added to the MY LAYERS panel (4), then tap the Explore Map button. You can then view the different environmental science layers using the MY LAYERS panel (4).

In the MY LAYERS panel, tick a box to view the layer on the map. Tick another box to view another layer. Only one science layer can be viewed at a time on the map. However, for many layers, you can turn on or off specific features (classes) within a layer to view just those classes on the map you are interested in.

N.B. For certain layers, you may need to zoom in or out of the map, before that layer becomes visible. You should see a message like "Water Yield becomes visible when zoomed out". This ensures you are not viewing maps at inappropriate scales.


 

View information for a particular location / area

You can view a report for a selected layer in the ADD FEATURES / FEATURE REPORT panel (Fig.3).

You can obtain reports either for a single location, for an area you define yourself on the map, the current map extent (window), or for areas (polygons) you select on the map from either the LINZ property boundaries, Māori Land Blocks, Territorial Authorities or the Regional Councils layers.

Step 1) If you haven't already down so, choose a science layer to display on the map. Reports are displayed faster if you have zoomed in to a small area on the map.

Step 2) Choose what you want the report to be based upon. Choices are: drop pin Drop pin on map, draw area Draw area on map, map extent Use map extent, or "Predefined features", such as polygons you select from LINZ Parcels, Māori Land Blocks, Territorial Authorities or Regional Councils.

Step 2a) DROP PIN: the report will be generated by you touching on a location on the map. A pin marker will appear at the location you have touched.

Step 2b) MAP EXTENT: the report will be generated using the current visible extent, in the map window. Choosing this option will then generate a report for the map extent.

Step 2c) AN AREA YOU DRAW: the report will be generated using an area defined/drawn by you. If you choose this option you need to define your area by touching multiple times around the map, to create a custom area.

  • Touch on the map to add a point and begin drawing
  • Subsequent touches will add additional points
  • Touch back close to the starting point, or double tap anywhere, to finish and generate a report.

Step 2d) "Predefined features": the report will be generated from the selected LINZ property boundary / Māori Land Block / Territorial Authority (TA) or Regional Council (RC). Choosing this option will switch on the corresponding layer (if not currently on) and it will be displayed on the map. You must then tap on the map within the area you want included in the report. The area you have selected will be highlighted. A report will be generated for that area. If you tap on additional parcel / area, they will be highlighted and the values will be added to the report. To remove a parcel / area from the report, tap inside the parcel / area again to deselect it. To deselect all parcels / areas and start again, tap START AGAIN. Note that the LINZ property boundaries and Māori Land Block layers are best viewed at a large scale (zoomed in), perhaps at 1:25,000, although for very rural areas you will probably need to view the map at smaller scales (more zoomed out). Similarly, the Territorial Authorities and Regional Councils layers are best viewed at smaller scales (zoomed out), perhaps at 1:2,000,000. Below the generated report, there is a switch which allows you to show / hide the layer in question.

Once the report has been requested using one of the above methods, this panel will change to FEATURE REPORT and a report preview will appear. The form of this report depends which type of report has been chosen. For example, if you chose "Drop pin on map", a textual report will appear listing attributes about that location, key properties, the Easting/Northing coordinates for that location, and an approximate height. If you chose "Draw area on map" or one of the predefined features options, the report preview will be in the form of a chart, with information relating to the classes that make up the chosen map layer.


add feats > feat report Fig. 3. ADD FEATURES panel becomes FEATURE REPORT panel, after report is generated.

Select the BACK button to go back to Step 2.

If you choose another science layer (by tapping the layer name to open a dropdown menu), the report will be automatically updated. However, the report is NOT updated if you pan or zoom to another location. In this case you will need to select the BACK button, and start again at Step 2.

Important things to be aware of:

  • The larger the geographic extent of the map, the longer it will take for the report to be calculated and the report displayed. In some cases, because of the complexity of the underlying data, the reporting tool will not work if the map is displaying a very large geographic extent.

 

Share a report

Select the SHARE button to generate a link for the report you have chosen. Please note, this option is only available if you are registered, and logged in. This link can then be shared with others e.g. in an email. If the person receiving the link clicks on it, their browser will open, Our Environment will load, they then need to log in and then the area report you specified will be displayed to them. The individual provided with the link will need to be a registered Our Environment user.

 

Saving your Pins / Features

If you have registered, and are logged in, you can save your pin / feature so that it's available when you login again later. If you want you can give the pin / feature a name. Do this before tapping the SAVE button. Choosing SAVE will add the pin to the MY FEATURES panel (5). Pins are stored and will appear in the MY FEATURES panel when you next use Our Environment. You can delete saved pins using the DELETE button.

Deleting Pins / Features

You can delete a pin or feature by tapping REMOVE in the FEATURE REPORT panel.


 

Download the underlying data

We provide a link, Obtain Data in the Layer METADATA if the data used to produce a map layer is available for downloading. If you tap on the link, the relevant page from the website hosting the data will appear in a new browser window. In most cases this will be Manaaki Whenua's LRIS Portal.


 

Printing a map

Use the Print facility (2g) to create printable PDF maps in A4 and A3 size, in portrait or landscape layout and at various scales.

Touch the  Print Map icon to open the PRINT window. The extent of your map is shown by the pink box. Touch the box and drag it around to change the geographic location of your map.

Changing the scale or paper size will affect the amount of detail or the size of the geographic area that will appear on the map.

You can enter a title for the map.

To request the PDF file, tap the 'CREATE AND DOWNLOAD MAP' button.

Note that the time it takes to create the PDF file will vary depending upon the complexity, size and scale of the map. You may have to wait a couple of minutes for the file to be created and downloaded. Depending on how your computer and browser are set up, you will either be able to view the PDF file directly or save it to your computer.


 

More advanced map features

 

Adding custom layers (*Experimental feature*)

Our Environment Online can display third party maps that are served with the Web Map Tile Service (WMTS) protocol or Esri ArcGIS REST API. To add a third party layer press the "Add 3rd party layer" button which is in the "Configure your map" window. This window is accessed via the "ADD/REMOVE LAYERS" button.

WMTS

Paste a WMTS capabilities URL in the box provided, and tap the LOAD button. If the URL is valid, you will be presented with the layers available via that service. Choose which group you would like the layer to be added (Context / Science / Basemap), and tap the tick button. The layer will be added in to the LAYERS panel. For example, tap here to use the layers from Manaaki Whenua's Web Map Services.

You can find some compatible maps at:

This feature works best with maps that are in the NZTM projection but we try to re-project on the fly if the maps are in a different projection. The WMTS service obviously needs to provide maps that cover or fall entirely within New Zealand. You will see an error message if the map coverage is outside of New Zealand.

Esri ArcGIS REST API

Paste a Esri ArcGIS REST API URL in the box provided, and tap the LOAD button. If the URL is valid, you will see information relating to the layer - tap the tick button to confirm and add the layer to your map. The URL for the service should end with:

  • /MapServer - for example NZ Imagery
  • /MapServer/{a number} e.g. /MapServer/0 /MapServer/1 /MapServer/2 etc.
  • /ImageServer - for example NZ Bathymetry 250m

You can find some compatible maps at:

  • data.govt.nz - when you select a dataset, choose the Esri REST API option, then paste the URL of the resource into the text box above.
  • Living Atlas - when you tap on a layer, you will be shown a page with information about the layer. To import this into Our Environment, copy the links that are in the section titled Layers.

 

Altering the transparency of a map layer

You can use the Layer Transparency slider (1b) to vary the transparency of a science layer displayed on the map. This allows you to gradually fade-in/fade-out the layer against the basemap.

 

Changing the underlying base map

By default, map layers are shown on top of a topographic map. However, some map layers are easier to read on top of alternative base maps (e.g. "monochrome topographic"). You can change the basemap by selecting a different base map in the MY LAYERS panel (4).

 

Resetting the map back to a national extent

At any time you can tap the globe icon on the top bar to reset the map extent back to the whole of New Zealand.

 

Returning to a previous map view

Use the back arrow in the toolbar to see the maps you were looking at previously. You can also use the forward arrow to go forward through the maps you have looked at previously.

 

Maximise the size of the map you can see on the screen

You can hide all various information panels, thus increasing the size of the map you can see on the screen. To do this, touch the name / icon of the panel you wish to minimise. Tapping on the name / icon again, opens the panel.

 

Go Full Screen

You can make the browser window go into full screen mode by tapping on the  button.

New Zealand Landcover Explorer

This is a currently experimental map tool that allows you to view changes and issues relating to New Zealand's land cover, by exploring different versions and 'views' of the Landcover Database NZ.

To access it, select the "Maps & Tools" > "Explore Landcover" option from the menu at the top of the page (or touch here). On first load of the tool, it is recommended to choose the "Take a tour" option from the popup window, as this will give you a quick overview of how the site works.

N.B.

  • Landcover maps don't appear until you zoom in to the map to around 1:550k.
  • The direction of change buttons: landcover explorer button landcover explorer button allow you to switch the map between looking at where land cover has become a particular type and where land cover is no longer a particular type.

Back to First Time Here

Quick Links

Use one of the links below to jump to what you're keen to learn about.

About the map page

How to find a location on the map

About our map layers

How to create reports

More advanced features

 

The Home Page

The home page provides various buttons and links to help you navigate around the site.

Touching the explore maps button Explore the Atlas button or the Maps & Tools > Explore NZ Land Atlas link in the menu will take you to a page where you can select and view environmental maps of New Zealand.

Touching the locate me button Locate me button will take you to the map page, with the map displayed showing your current location. This functionality is enabled only if you are located within New Zealand.

Finally, tapping the first time here button First time here? button will bring you to this page.


 

Exploring the maps and science data

The map page consists of a main map window, surrounded by a series of panels and controls which enable map navigation, map viewing, querying for data and reporting of the map layers.

map page main Fig. 1. Map page.

  1. Main menu - Contains links to all major sections of the site.
  2. LAYERS panel - Control which layers are drawn. Tick check boxes to turn layers on or off. Click layer name to view layer information, which will be displayed in the LEGEND panel. Learn more.
  3. SEARCH panel - Search for a particular location using geographic coordinates, a place name or an address. Learn more.
  4. MY FEATURES panel - Saved pins and features, generated from the FEATURES panel, will appear here.
  5. LEGEND panel - Displays a map key.
  6. Zoom buttons - Zoom in and out of the map.
  7. Layer transparency - Alter the transparency of the environmental science layers.
  8. Map window - Interact with and view maps.
  9. Locate me - Zoom map to your current location.
  10. Attribution - Copyright information.
  11. Settings - Displays the advanced settings window. In this window you can change the image resolution of the map, allow more control of map layers, and change the interaction style between mouse and touch (if you have a touch enabled device).
  12. ADD FEATURES menu - Generate reports by touching the map to add pins, areas (polygons) or choose from predefined areas. Learn more.


 

Interacting with the map

To move around the map, tap and drag the map to pan (move) to another location.

Use one of the following to zoom into the map (see more detail) and zoom out of the map (see less detail).

  • Use the zoom buttons (6).
  • Double-tap to zoom in closer or use a pinch action to zoom in and out.


 

Finding a particular place on the map

If you are looking for a particular place, the quickest way to find it is to use the SEARCH tool (3). Searching works with geographic coordinates, a place name or an address.

To search using coordinates, type the coordinates into the search box. You can type NZTM coordinates (e.g. 1890671, 5819114) or latitude-longitude (e.g. -37.73, 176.29).

In all cases, the place you are looking for is shown on the map by a red flashing dot.


 

Viewing map layers including environmental science layers

When you first use the mapping tool, you will be presented with a popup window and asked to select one or more environmental science layers to view on the map.

You can view the different layers using the LAYERS panel (2).

Make sure the LAYERS panel is expanded by tapping the  button. Tick a box to view the layer on the map. Tick another box to view another layer. Only one science layer can be viewed at a time on the map.


 

View information for a particular location / area

You can view a report for a selected layer using the ADD FEATURES menu, accessed via thedrop pin button. Tapping this button opens the ADD FEATURES menu (Fig.2).


add features menu Fig. 2. Add Features menu.

You can obtain reports either for a single location, for an area you define yourself on the map, the current map extent (window), or for areas (polygons) you select on the map from either the LINZ property boundaries, Māori Land Blocks, Territorial Authorities or the Regional Councils layers.

Step 1) If you haven't already down so, choose a science layer to display on the map. Reports are displayed faster if you have zoomed in to a small area on the map.

Step 2) Choose what you want the report to be based upon. Choices are: drop pin Drop pin on map, draw area Draw area on map, map extent Use map extent, or "Predefined features", such as polygons you select from LINZ Parcels, Māori Land Blocks, Territorial Authorities or Regional Councils.

Step 2a) DROP PIN: the report will be generated by you touching on a location on the map. A pin marker will appear at the location you have touched.

Step 2b) MAP EXTENT: the report will be generated using the current visible extent, in the map window. Choosing this option will then generate a report for the map extent.

Step 2c) AN AREA YOU DRAW: the report will be generated using an area defined/drawn by you. If you choose this option you need to define your area by touching multiple times around the map, to create a custom area.

  • Touch on the map to add a point and begin drawing
  • Subsequent touches will add additional points
  • Touch back close to the starting point, or double tap anywhere, to finish and generate a report.

Step 2d) "Predefined features": the report will be generated from the selected LINZ property boundary / Māori Land Block / Territorial Authority (TA) or Regional Council (RC). Choosing this option will switch on the corresponding layer (if not currently on) and it will be displayed on the map. You must then tap on the map within the area you want included in the report. The area you have selected will be highlighted. A report will be generated for that area. If you tap on additional parcel / area, they will be highlighted and the values will be added to the report. To remove a parcel / area from the report, tap inside the parcel / area again to deselect it. To deselect all parcels / areas and start again, tap START AGAIN. Note that the LINZ property boundaries and Māori Land Block layers are best viewed at a large scale (zoomed in), perhaps at 1:25,000, although for very rural areas you will probably need to view the map at smaller scales (more zoomed out). Similarly, the Territorial Authorities and Regional Councils layers are best viewed at smaller scales (zoomed out), perhaps at 1:2,000,000. Below the generated report, there is a switch which allows you to show / hide the layer in question.

Once the report has been requested using one of the above methods, this panel will change to FEATURE REPORT and a report preview will appear. The form of this report depends which type of report has been chosen. For example, if you chose "Drop pin on map", a textual report will appear listing attributes about that location, key properties, the Easting/Northing coordinates for that location, and an approximate height. If you chose "Draw area on map" or one of the predefined features options, the report preview will be in the form of a chart, with information relating to the classes that make up the chosen map layer.

 

If you choose another science layer (by tapping the layer name to open a dropdown menu), the report will be automatically updated. However, the report is NOT updated if you pan or zoom to another location. In this case you will need to select the BACK button, and start again at Step 2.

Step 3) Full Report: Touch the "Generate full report" button, and a more detailed report will be generated for the location / area in question. This opens in a new window an example of which can be seen below in Fig. 3. The report is then accessible in your MY FEATURES panel, after you close the report window.


report window

Fig. 3. Report window.

In this window you can interact with the report in a variety of ways:

  • Edit the report title - Click  button to go into edit mode, and edit text in the grey box at the top of the report.
  • View the location / area of the report in a mini map in the top right of the report window.
  • Add / remove data layers to / from the report - Click on the "Add/remove layers" button, and check / uncheck required layers from the resultant window.
  • Change the visualisation type by clicking on the buttons directly above the chart - choose from Bar, Tree, Bubble or Table.
  • Generate a shareable link to the report by clicking the  button.
  • Print the report by clicking the  button and following the instructions in the print window dialog.

Important things to be aware of:

  • The larger the geographic extent of the map, the longer it will take for the report to be calculated and the report displayed. In some cases, because of the complexity of the underlying data, the reporting tool will not work if the map is displaying a very large geographic extent.

Share a report

Select the SHARE button to generate a link for the report you have chosen. Please note, this option is only available if you are registered, and logged in. This link can then be shared with others e.g. in an email. If the person receiving the link clicks on it, their browser will open, Our Environment will load, they then need to log in and then the area report you specified will be displayed to them. The individual provided with the link will need to be a registered Our Environment user.

 

Saving your Pins / Features

If you have registered, and are logged in, you can save your pin / feature so that it's available when you login again later. If you want you can give the pin / feature a name. Do this before tapping the SAVE button. Choosing SAVE will add the pin to the MY FEATURES panel (4). Pins are stored and will appear in the MY FEATURES panel when you next use Our Environment. You can delete saved pins using the DELETE button.

Deleting Pins / Features

You can delete a pin or feature by tapping REMOVE in the FEATURE REPORT panel.

 

Learning more about a map layer

Further details about particular features (classes) making up a layer can be found in the LEGEND panel (5). To view this information, tap on a layer in the LAYERS panel (2), then open the LEGEND panel.


 

More advanced map features

Altering the transparency of a map layer

You can use the Layer Transparency slider (7) to vary the transparency of a layer displayed on the map. This allows you to gradually fade-in/fade-out the layer against the basemap.

Changing the underlying base map

By default, map layers are shown on top of a topographic map. However, some map layers are easier to read on top of alternative base maps (e.g. "monochrome topographic"). You can change the basemap by selecting a different base map in the LAYERS panel (2).